您的位置:首页 > 其它

poj1523 割点+连通分量

2015-02-04 15:35 369 查看
SPF

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6477 Accepted: 2965
Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from
communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected
network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 



Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers
will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when
that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.
Sample Input
1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output
Network #1
SPF node 3 leaves 2 subnets

Network #2
No SPF nodes

Network #3
SPF node 2 leaves 2 subnets
SPF node 3 leaves 2 subnets


首先理解一些基本概念:

树边:dfs树中的边
回边(反向边):原图中存在的但不在dfs树中的边
交叉边(横叉边): 原图中不存在的边,在dfs树中横跨两个子树

割点的充要条件:
根节点,有大于1个孩子节点
‚非根节点,至少存在一个孩子节点,其low值>=父亲节点的dfn值

#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 1010
using namespace std;

/*
low[u]表示从u或者u的子孙出发通过回边可以到达的最小深度优先数
low[u]=min(
dfn[u],
min(low[v]|v为u的孩子节点),
min(dfn[v]|(u,v)为回边)
)
*/
int adj[Maxn][Maxn],vis[Maxn];
int dfn[Maxn],low[Maxn];
int subnets[Maxn]; //非根节点需要+1
int n; //节点总数
int tmpdfn; //时间戳
void dfs(int u){
vis[u]=1;
dfn[u]=low[u]=tmpdfn;
for(int i=1;i<=n;i++){
//v和u邻接,在生成树中就是2种情况
//v是u的祖先节点或者孩子节点
if(!adj[u][i]) continue;
if(!vis[i]){ //孩子节点
tmpdfn++;
dfs(i);
//回退的时候,计算顶点u的low值
low[u]=min(low[u],low[i]);
if(low[i]>=dfn[u]) //统计连通分量个数
subnets[u]++; //根节点dfn[u]=1,因此必有low[v]>=dfn[u]
}
else //祖先节点,(u,i)为回边
low[u]=min(low[u],dfn[i]);
}
}
void init(){
tmpdfn=1;
memset(vis,0,sizeof vis);
memset(subnets,0,sizeof subnets);
}
int main()
{
int a,b,cas=1;
while(scanf("%d",&a),a){
scanf("%d",&b);
n=0;
memset(adj,0,sizeof adj);
adj[a][b]=adj[b][a]=1;
n=max(n,a);
n=max(n,b);
while(scanf("%d",&a),a){
scanf("%d",&b);
adj[a][b]=adj[b][a]=1;
n=max(n,a);
n=max(n,b);
}
init();
dfs(1);
if(cas!=1) puts("");
printf("Network #%d\n",cas++);
bool flag=false;
if(subnets[1]>1) flag=true;
for(int i=2;i<=n;i++)
if(++subnets[i]>1) flag=true;
if(!flag) puts("  No SPF nodes");
else{
for(int i=1;i<=n;i++){
if(subnets[i]>1)
printf("  SPF node %d leaves %d subnets\n",i,subnets[i]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: