您的位置:首页 > 其它

HDU 2126 Buy the souvenirs

2015-02-04 15:31 281 查看


Buy the souvenirs


Time Limit: 10000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1283 Accepted Submission(s): 454



Problem Description

When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but
also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few.
So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top
coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7),
ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).

Input

For the first line, there is a T means the number cases, then T cases follow.

In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir.

All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.

Output

If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can
buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”

Sample Input

2
4 7
1 2 3 4

4 0
1 2 3 4


Sample Output

You have 2 selection(s) to buy with 3 kind(s) of souvenirs.
Sorry, you can't buy anything.


题目大意:

告诉你有几种纪念品以及分别对应的价格,要你用手中的钱去买纪念品,然后求出最多能买多少种纪念品以及最优方案数目。

大致思路:

这是一道01背包题目。要求最多能买多少种不难,难的是求出最优方案一共有多少种组合。

至于如何求最优方案数目,请看此文:
http://blog.csdn.net/mengt2012/article/details/43491859
知道如何求解最优方案,基本代码就出来了。一开始写的代码老是WA…后来才知道fill(kry, kry+maxm+1, INF)越界了…

代码如下:

//2126.cpp -- Buy the souvenirs
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iomanip>
typedef long long ll;
using namespace std;
const int maxn = 30 + 10;
const int maxm = 500 + 10;
const int INF = 1;
int n, m;
int w[maxn], dp[maxm], kry[maxm];
void solve()
{
fill(kry, kry+maxm, INF );
memset(dp, 0, sizeof(dp));
for( int i=1; i<=n; i++ )
{
for( int j=m; j>=w[i]; j-- )
{
if( dp[j]<dp[j-w[i]]+1)
{
dp[j] = dp[j-w[i]] + 1;
kry[j] = kry[j-w[i]];
}
else if( dp[j]==dp[j-w[i]]+1)
kry[j] = kry[j] + kry[j-w[i]];
}
}
/*
for(int j=0; j<maxm; j++ )
kry[j] = 1;
memset(dp, 0, sizeof(dp));
for( int i=1; i<=n; i++ )
{
for( int j=1; j<=m; j++ )
{
dp[i][j] = dp[i-1][j];
kry[i][j] = kry[i-1][j];
if( j>=w[i] )
{
if( dp[i][j]<dp[i-1][j-w[i]]+1 )
{
dp[i][j] = dp[i-1][j-w[i]] + 1;
kry[i][j] = kry[i-1][j-w[i]];
}
else if( dp[i][j]==dp[i-1][j-w[i]]+1 )
kry[i][j] = kry[i-1][j] + kry[i-1][j-w[i]];
}
}
}
*/
if( dp[m]!=0 )
printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n", kry[m], dp[m]);
else
printf("Sorry, you can't buy anything.\n");
}
int main(void)
{
int t;
cin>>t;
while( t-- )
{
cin>>n>>m;
for( int i=1; i<=n; i++ )
scanf("%d", &w[i]);
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: