您的位置:首页 > 其它

zoj 1240 IBM Minus One

2015-02-04 15:21 337 查看
IBM Minus One

Time Limit: 2 Seconds Memory Limit: 65536 KB

You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew
is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story
ends, in case you want to read the book for yourself :-)
After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic
ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.
Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

Input
The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

Output
For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time
by the following letter in the alphabet, and replacing 'Z' by 'A'.
Print a blank line after each test case.

Sample Input
2

HAL

SWERC

Sample Output
String #1

IBM
String #2

TXFSD

分析:

此题,很水。反正现在在做水题。。。
按题意,输出的字母是输入字母的后一个,Z的后一个字母为A。
代码:

#include <cstdio>

int n;
char c;

int main() {
scanf("%d", &n);
getchar();
for (int i = 1; i <= n; i++) {
printf("String #%d\n", i);
while (~scanf("%c", &c) && c!= '\n') {
if (c < 'Z')
putchar(c + 1);
else
putchar('A');
}
puts("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: