您的位置:首页 > 大数据 > 人工智能

poj3691--DNA repair(AC自动机+dp)

2015-02-04 08:16 253 查看
DNA repair

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5743 Accepted: 2693
Description

Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters 'A', 'G' , 'C' and 'T'. The repairing techniques are simply
to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA "AAGCAG" to "AGGCAC" to eliminate the initial causing disease segments "AAG", "AGC" and "CAG" by changing two characters. Note that the repaired DNA can
still contain only characters 'A', 'G', 'C' and 'T'.

You are to help the biologists to repair a DNA by changing least number of characters.

Input

The input consists of multiple test cases. Each test case starts with a line containing one integers
N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases.

The following N lines gives N non-empty strings of length not greater than 20 containing only characters in "AGCT", which are the DNA segments causing inherited disease.

The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in "AGCT", which is the DNA to be repaired.
The last test case is followed by a line containing one zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by the

number of characters which need to be changed. If it's impossible to repair the given DNA, print -1.

Sample Input
2
AAA
AAG
AAAG
2
A
TG
TGAATG
4
A
G
C
T
AGT
0

Sample Output
Case 1: 1
Case 2: 4
Case 3: -1

对给出的得病的串进行自动机构造,dp[i][j]对应了走i步从根到达第j个节点的最小值。

 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std ;
#define INF 0x3f3f3f3f
struct node{
int flag , id ;
node *next[4] , *fail ;
} tree[2100] ;
queue <node *> que ;
int num , dp[1100][2100] ;
char str[2100] ;
char c[5] = "ACGT" ;
node *newnode()
{
node *p = &tree[num] ;
p->flag = 0 ;
p->id = num++ ;
p->fail = NULL ;
for(int i = 0 ; i < 4 ; i++)
p->next[i] = NULL ;
return p ;
}
void settree(char *s,node *rt)
{
int i , k , l = strlen(s) ;
node *p = rt ;
for(i = 0 ; i < l ; i++)
{
for(k = 0 ; k < 4 ; k++)
if( s[i] == c[k] )
break ;
if( p->next[k] == NULL )
p->next[k] = newnode() ;
p = p->next[k] ;
}
p->flag = 1 ;
return ;
}
void setfail(node *rt)
{
node *p = rt , *temp ;
p->fail = NULL;
while( !que.empty() ) que.pop() ;
que.push(p) ;
while( !que.empty() )
{
p = que.front() ;
que.pop() ;
for(int i = 0 ; i < 4 ; i++)
{
if( p->next[i] )
{
temp = p->fail ;
while( temp && !temp->next[i] )
temp = temp->fail ;
p->next[i]->fail = temp ? temp->next[i] : rt ;
que.push(p->next[i]) ;
if( temp && temp->flag )
p->flag = 1 ;
}
else
p->next[i] = p == rt ? rt : p->fail->next[i] ;
}
}
return ;
}
int query(char *s,node *rt)
{
int i , j , k , l = strlen(s) , flag ;
memset(dp,INF,sizeof(dp)) ;
dp[0][0] = 0 ;
for(i = 0 ; i < l ; i++)
{
for(j = 0 ; j < num ; j++)
{
for(k = 0 ; k < 4 ; k++)
{
if( tree[j].next[k]->flag ) continue ;
if( s[i] == c[k] )
dp[i+1][ tree[j].next[k]->id ] = min( dp[i][j] , dp[i+1][ tree[j].next[k]->id ] ) ;
else
dp[i+1][ tree[j].next[k]->id ] = min( dp[i][j]+1 , dp[i+1][ tree[j].next[k]->id ] ) ;
}
}
/*for(j = 0 ; j < num ; j++)
printf("%d ", dp[i+1][j]) ;
printf("\n") ;*/
}

int ans = INF ;
for(i = 0 ; i < num ; i++)
ans = min(ans,dp[l][i]) ;
if( ans == INF )
ans = -1 ;
return ans ;
}
int main()
{
int i , n , temp = 1 ;
node *rt ;
while( scanf("%d", &n) && n )
{
num = 0 ;
rt = newnode() ;
for(i = 0 ; i < n ; i++)
{
scanf("%s", str) ;
settree(str,rt) ;
}
setfail(rt) ;
scanf("%s", str) ;
printf("Case %d: %d\n", temp++ , query(str,rt) ) ;
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: