您的位置:首页 > 其它

(hdu step 2.3.4)How Many Trees?(大数:求n个节点能够成多少棵二叉树)

2015-02-03 18:16 363 查看
在写题解之前给自己打一下广告哈~

。。抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下:http://edu.csdn.net/course/detail/209
题目:        

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 976 Accepted Submission(s): 511
 
[align=left]Problem Description[/align]A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
 
[align=left]Input[/align]The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 
[align=left]Output[/align]You have to print a line in the output for each entry with the answer to the previous question.
 
[align=left]Sample Input[/align]
1
2
3
 
[align=left]Sample Output[/align]
1
2
5
 
题目大意:               给你一个n个节点,问能够成多少棵二叉树。题目分析:              简单题,只要知道有这个公式就好。卡特兰公式的一个应用就是用来求“给出n个节点,问能够成多少棵二叉树”。an =C(2n,n)/(n+1)=(4n-2)*(an-1 )/(n+1)

先花O(n)时间打表,把前100项的结果全部算出来。以后就是O(1)的时间输出结果
代码如下:import java.math.BigInteger;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
BigInteger catalans[] = new BigInteger[101];

BigInteger four = new BigInteger("4");
BigInteger two = new BigInteger("2");
BigInteger one = new BigInteger("1");

catalans[1] = new BigInteger("1");

int i;
for(i = 2 ; i <= 100 ; ++i){
catalans[i] = catalans[i-1].multiply(four.multiply(BigInteger.valueOf(i)).subtract(two)).divide(BigInteger.valueOf(i+1));
}

Scanner scanner = new Scanner(System.in);
while(scanner.hasNext()){
int n = scanner.nextInt();
System.out.println(catalans
);
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: