您的位置:首页 > 产品设计 > UI/UE

HDU-A Fibonacci sequence斐波那契数列-大数求和

2015-02-03 15:01 183 查看
问题及代码:

/* 
*Copyright (c)2014,烟台大学计算机与控制工程学院 
*All rights reserved. 
*文件名称:Fibonacci.cpp 
*作    者:单昕昕 
*完成日期:2015年2月3日 
*版 本 号:v1.0 
* 
*问题描述:A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
*程序输入:Each line will contain an integers. Process to end of file.
*程序输出:For each case, output the result in a line.
Sample Input
100
Sample Output
4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
*/
#include<stdio.h>
int n,i,j,ans[8000][255]= {{0}};
int main()
{
    for(i=1; i<5; i++)ans[i][1]=1;
    for(i=5; i<8000; i++)
        for(j=1; j<255; j++)
        {
            ans[i][j]+=ans[i-1][j]+ans[i-2][j]+ans[i-3][j]+ans[i-4][j];
            ans[i][j+1]+=ans[i][j]/100000000;
            ans[i][j]=ans[i][j]%100000000;

        }
    while(scanf("%d",&n)!=EOF)
    {
        for(i=254; i>0; i--)
            if(ans
[i])break;
        printf("%d",ans
[i]);
        for(--i; i>0; i--)
            printf("%.8d",ans
[i]);
        printf("\n");
    }
    return 0;
}


运行结果:



知识点总结:

斐波那契数列-大数求和。

学习心得:

又是大数求和,套了个斐波那契数列的帽子。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: