您的位置:首页 > 其它

POJ 题目3096 Surprising Strings(map 水)

2015-02-02 15:44 316 查看
Surprising Strings

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6082Accepted: 3972
Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible
distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG
is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input
ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output
ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

Source

Mid-Central USA 2006

ac代码

#include<stdio.h>
#include<map>
#include<string.h>
#include<string>
#include<iostream>
using namespace std;
int main()
{
char s[101];
while(scanf("%s",s)!=EOF)
{
int i,j,len,d,w=1;
if(s[0]=='*')
break;
len=strlen(s);
d=len-2;
for(i=1;i<=len;i++)
{
map<string,int>m;
for(j=0;j+i<len;j++)
{
char str[3]={s[j],s[j+i],'\0'};
if(!m[str])
m[str]=1;
else
{
w=0;
break;
}
}
if(!w)
break;
}
if(w)
printf("%s is surprising.\n",s);
else
printf("%s is NOT surprising.\n",s);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: