您的位置:首页 > 其它

Sum It Up(HDU 1258)

2015-02-01 12:20 253 查看

Sum It Up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4416 Accepted Submission(s): 2285



Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2,
and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise,
t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order,
and there may be repetitions.

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order.
A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums
with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0


Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


Source
浙江工业大学第四届大学生程序设计竞赛


这个dfs的题目我想了挺久都不会写,我。。不说了。。还是看了别人的思路才会的+_+

题意:
给你一个含n个数字的非升序数列,让你输出所有组成和为 t 的数,没有则输出NONE。

--------------------------------------------------------------------------------------------------------------------
就是搜啊搜啊搜,把搜到的放到另一个数组中去。1.已搜到和为t的组成时,把组成中的最后一个数去掉,重新搜。2.当超过t时,组成也减少一个,重新搜。3.判断重复:如果当前搜到的数和上次搜的数是相同的,①如果是没到达t而继续搜的就可以继续搜。②如果是由于“大于等于t”而造成重新搜的情况就要跳过这个重复的搜。

code:
#include<stdio.h>
int t, n, flag, bi, a[15], b[15];

void dfs(int x,int sum)
{
    if(sum > t) return ;
    if(sum == t)
    {
        flag = 1;
        printf("%d", b[0]);
        for(int i=1; i<bi; i++)
            printf("+%d", b[i]);
        puts("");
        return ;
    }
    int temp = -1;
    for(int i=x; i<n; i++)
    {
        if(a[i] != temp)
        {
            b[bi++] = a[i];
            temp = a[i];
            dfs(i+1,sum+a[i]);
            bi--;
        }
    }
}

int main()
{

    while(~scanf("%d%d", &t,&n),n)
    {
        for(int i=0; i<n; i++)
            scanf("%d", a+i);
        flag = bi = 0;
        printf("Sums of %d:\n", t);
        dfs(0,0);
        if(!flag) puts("NONE");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: