您的位置:首页 > 其它

uva 193 Graph Coloring(回溯)

2015-02-01 12:01 330 查看

uva 193 Graph Coloring

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black.
The coloring is restricted by the rule that no two connected nodes may be black.




Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers

,


, and a set of undirected edges denoted by pairs of node numbers


,


. The input file contains
m graphs. The number m is given on the first line. The first line of each graph contains
n and k, the number of nodes and the number of edges, respectively. The following
k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring.
It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5


题目大意:给定n个节点,节点的编号为1-n,在给定m个节点链接的信息,现在要求对节点图色,只有两种颜色可以黑色和白色并且相邻的节点不能同时为黑色但是可以为白色,要求黑色节点最多的个数,以及一组节点的编号

解题思路:
刚开始所有点没有着色,且最终结果至少有一个点被着黑色(一个点时直接着黑色,多个点时,可以任选一个点为黑色,其余点全为白色);

枚举这个黑色的点,并且把与它相邻的点都着白色,剩下的可以看作是一个相同的子问题了,因为剩下的点都不与这个黑色的点相邻。

最优解满足:每个白色的点至少与一个黑色的点相邻(如果这个点相邻的都是白色,可以把它改为黑色),且每个黑色的点周围都是白色。

#include<stdio.h>
#include<string.h>
int gra[105][105], A[105], B[105], ans;
int n, m;
void DFS(int d, int num) {
	int temp[105], cnt;
	if (d > ans && num >= n) {
		ans = d;
		memcpy(B, A, sizeof(B));
		return;
	}
	for (int i = 1; i <= n; i++) {
		if (A[i] == 0) {
			A[i] = 2;
			cnt = 0;
			temp[cnt++] = i;
			for (int j = 1; j <= n; j++) {
				if (gra[i][j] && !A[j]) {
					A[j] = 1;
					temp[cnt++] = j;
				}
			} 
			DFS(d + 1, num + cnt);
			while (cnt) {
				A[temp[--cnt]] = 0;
			}
		}
	}
	return;
}
int main() {
	int T;
	scanf("%d", &T);
	while (T--) {
		memset(gra, 0, sizeof(gra));
		memset(A, 0, sizeof(A));
		memset(B, 0, sizeof(B));
		scanf("%d %d", &n, &m);
		int a, b;
		ans = 0;
		for (int i = 0; i < m; i++) { 
			scanf("%d %d", &a, &b);
			gra[a][b] = 1;
			gra[b][a] = 1;
		}
		DFS(0, 0);
		printf("%d\n", ans);
		int flag = 1;
		for (int i = 1; i <= n; ++i) {
			if (B[i] == 2)
			{
				if (flag) flag = 0;
				else putchar(' ');
				printf("%d", i);
			}
		}
		printf("\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: