您的位置:首页 > 其它

HDU2710 Max Factor【水题】【素因子】

2015-02-01 09:27 323 查看
Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4110    Accepted Submission(s): 1342

Problem Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular,
a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input

* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4

36

38

40

42

Sample Output

38

Source
USACO 2005 October Bronze

题目大意:给你N个数,找出这N个数拥有最大素因子的那个数。

思路:筛法求素数的方法求出所有20000范围内所有数最大的素因子,然后遍历N个数,

找出最大的即可。

#include<stdio.h>
#include<string.h>
#include<math.h>

int Prime[20005];

void IsPrime()
{
Prime[1] = 1;
for(int i = 2; i <= 20000; i++)
{
if(Prime[i]==0)
{
Prime[i]=i;
for(int j = i+i; j <= 20000; j+=i)
Prime[j] = i;
}
}
}

int main()
{
int N,x;
IsPrime();
while(~scanf("%d",&N))
{
int Max = 0;
while(N--)
{
scanf("%d",&x);
if(Prime[x] > Prime[Max])
Max = x;
}
printf("%d\n",Max);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: