您的位置:首页 > 其它

UVALive - 3135 - Argus (优先队列!!)

2015-02-01 00:14 399 查看
UVALive - 3135

Argus

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and
telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
Query-1: �Every five minutes, retrieve the maximum temperature over the past five minutes.� Query-2: �Return the average temperature measured on each floor over the past 10 minutes.�
We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing
data and return the results to the corresponding user with the desired frequency.
For the Argus, we use the following instruction to register a query:
Register Q_num Period
Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the
first time, and after that, the result will be returned every Period seconds.
Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries
are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the
same time. This part is ended with a line of �#�.
The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5


Sample Output

2004
2005
2004
2004
2005


Source

Regionals 2004 >> Asia
- Beijing


扩展知识:其实对于这题,,我们可以扩展到解决多路归并的问题,,即把k个有序表合并成一个有序表。。

这题就是最基础优先队列应用。。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

//优先队列中的元素 
struct Item
{
	int Qnum, Period, Time;
	//重要! 优先级比较函数。优先级高的先出队 
	bool operator < (const Item& a) const 
	{		//请注意,这里的const必不可少
		return Time > a.Time || (Time == a.Time && Qnum > a.Qnum); 
	}
};

int main()
{
	priority_queue<Item> pq;
	char s[20];
	
	while(scanf("%s", s) && s[0] != '#')
	{
		Item item;
		scanf("%d %d", &item.Qnum, &item.Period);
		item.Time = item.Period;		//初始化“下一次事件的时间”为它的周期 
		pq.push(item);
	}
	
	int K;
	scanf("%d", &K);
	while(K--)
	{
		Item r = pq.top();	//取下一个事件 
		pq.pop();
		printf("%d\n", r.Qnum);	
		r.Time += r.Period;		//更新该触发器的“下一个事件”的时间 
		pq.push(r); 			//重新插入优先队列 
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: