您的位置:首页 > 其它

POJ 1308 Is It A Tree? (并查集)

2015-01-31 17:25 417 查看
Is It A Tree?

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 23006Accepted: 7898
Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

North Central North America 1997

题意:给定一些边构成的图,问是不是树。

解析:树的特征:连通且无回路。判断连通可以用并查集,直接判断所有点的祖先都是同一个点即可;判断无回路,只需要在输入的时候判断每条边的两端点不在同一集合即可。

PS:第一次忘了初始化了~~~~(>_<)~~~~ 唉,调到死!!!

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
using namespace std;
#define INF 0x7fffffff
#define LL long long
#define MID(a, b)  a+(b-a)/2
const int maxn = 10000 + 10;

int pa[maxn], rank[maxn], vis[maxn];

void init(){
    for(int i=0; i<maxn; i++){
        pa[i] = i;
        rank[i] = 0;
        vis[i] = 0;
    }
}

int find(int x){
    return pa[x] == x ? x : pa[x] = find(pa[x]);
}

void unite(int x, int y){
    x = find(x); y = find(y);
    if(pa[x] != pa[y]){
        if(rank[x] < rank[y]) pa[x] = y;
        else{
            pa[y] = x;
            if(rank[x] == rank[y]) rank[x] ++;
        }
    }
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int u, v;
    int flag = 1, Case = 0;
    init();                              //不能忘~~~~(>_<)~~~~ 
    while(scanf("%d%d", &u, &v)!=EOF && !(u == -1 && v == -1)){
        if(!u && !v){
            Case ++;
            int foo = 0;
            int i, j;
            if(flag){                    //判连通
                for(i=1; i<maxn; i++)         
                    if(vis[i]){
                        foo = find(i);
                        break;
                    }
                for(j=1; j<maxn; j++){
                    if(vis[j] && find(j)!= foo){
                        flag = 0;
                        break;
                    }
                }
            }
            printf("Case %d %s\n", Case, flag ? "is a tree." : "is not a tree.");
            init();
            flag = 1;
            continue;
        }
        vis[u] = vis[v] = 1;
        if(find(u) == find(v)) flag = 0;            //判无回路
        else unite(u, v);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: