您的位置:首页 > 其它

POJ 2249 Binomial Showdown (连乘整商求组合数)

2015-01-31 16:49 791 查看
Binomial Showdown
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 18412Accepted: 5618
Description
In how many ways can you choose k elements out of n elements, not taking order into account?

Write a program to compute this number.
Input
The input will contain one or more test cases.

Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n).

Input is terminated by two zeroes for n and k.
Output
For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 231.

Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit.

Sample Input
4 2
10 5
49 6
0 0

Sample Output
6
252
13983816

Source
Ulm Local 1997

题目链接:http://poj.org/problem?id=2249

题目大意:就是求组合数Ckn

题目分析:连乘k个整商Ckn = n! / (k!*(n - k)!) = ((n - k + 1) / k) * ((n - k + 2) / (k - 1)) * ... * (n / 1)

#include <cstdio>
#define ll long long

ll cal(ll n, ll k)
{
    if(k > (n >> 1))
        k = n - k;
    ll a = 1, b = 1;
    for(int i = 1; i <= k; i++)
    {
        a *= n + 1 - i;
        b *= i;
        if(a % b == 0)
        {
            a /= b;
            b = 1;
        }
    }
    return a / b;
}

int main()
{
    ll n, k;
    while(scanf("%lld %lld", &n, &k) && (n + k))
        printf("%lld\n", cal(n, k));
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: