您的位置:首页 > 其它

1045. Favorite Color Stripe (30)

2015-01-30 22:30 344 查看
题目:

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length.
So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best
solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200)
followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by
a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.
Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:
7


注意:
1、这道题目的思路是先把问题转换为最长非连续子序列,然后使用动态规划的方法
2、首先将所给序列中不是Eva喜欢的颜色剔除掉,然后按照最长非连续子序列来处理(该处理方法可自行百度)
3、case 2和case 3分别是最长非连续子序列长度为1和0的情况,要小心,我在case 2上检查了很久才找出问题

代码:

#include<iostream>
#include<vector>
#include<map>
using namespace std;

int main()
{
int n,m,l;
scanf( "%d%d",&n,&m);
map< int,int >colorrank;
for(int i=0;i<m;++i)
{
int t;
scanf( "%d",&t);
colorrank.insert(pair< int,int >(t,i));
}
scanf( "%d",&l);
vector< int>favorate;//
for(int i=0;i<l;++i)
{ //if input color is the color she like, add this coloe's rank into the sequence
int t;
scanf( "%d",&t);
map< int,int >::iterator iter;
iter=colorrank.find(t);
if(iter!=colorrank.end())
favorate.push_back(iter->second);
}
//if favorate.size()=0,maxlen=0;if favorate.size()=1,maxlen=1%%%%%for case 2 and case3
int maxlen=favorate.size()>0?1:0;
vector< int>len(favorate.size(),1);
for(int i=1;i<favorate.size();++i)
{ //find in the sequence if there is a color in front of the current that rank before it
for(int j=0;j<i;++j)
if(favorate[j]<=favorate[i])
len[i]=len[j]+1>len[i]?len[j]+1:len[i];
maxlen=len[i]>maxlen?len[i]:maxlen;
}
printf( "%d\n",maxlen);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: