您的位置:首页 > 其它

1032. Sharing (25)

2015-01-30 22:16 316 查看
题目:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.



Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total
number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, andNext is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:
-1


注意:
1、我这里使用data[i]来记录i的下一个地址,并使用两个vector来记录这两个字符串。
2、在查询共享地址时,从后到前来找到最早开始共享的地址。

代码:

#include<iostream>
#include<vector>
using namespace std;
int data[100000];//data[i] is the next data address if i
int main()
{
int s1,s2,n;
vector< int>list1,list2;
cin>>s1>>s2>>n;
list1.push_back(s1);
list2.push_back(s2);
for(int i=0;i<n;++i)
{
int add,next;
char value;
cin>>add>>value>>next;
data[add]=next;
}
while(list1[list1.size()-1]!=-1)
list1.push_back(data[list1[list1.size()-1]]);
while(list2[list2.size()-1]!=-1)
list2.push_back(data[list2[list2.size()-1]]);
int k;
while(list1.size()>0 && list2.size()>0 && list1[list1.size()-1] == list2[list2.size()-1])
{
k=list1[list1.size()-1];
list1.pop_back();
list2.pop_back();
}
if(k==-1)
cout<<k<<endl;
else
printf( "%05d\n",k);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: