您的位置:首页 > 其它

HDOJ 题目1253 胜利大逃亡(BFS)

2015-01-29 15:57 260 查看

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27498 Accepted Submission(s): 10481



[align=left]Problem Description[/align]
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.



[align=left]Input[/align]
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

[align=left]Output[/align]
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

[align=left]Sample Input[/align]

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0


[align=left]Sample Output[/align]

11


[align=left]Author[/align]
Ignatius.L

[align=left]Recommend[/align]
Ignatius.L | We have carefully selected several similar problems for you: 1372 1242 1240 1175 1026
ac代码
#include<stdio.h>
#include<string.h>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
#define INF 0xfffffff
int map[60][60][60],v[60][60][60];
int ans;
int dx[6]={-1,1,0,0,0,0};
int dy[6]={0,0,-1,1,0,0};
int dz[6]={0,0,0,0,-1,1};
int A,B,C,T;
struct s
{
int x,y,z,time;
};
int check(struct s a)
{
if(a.x<0||a.y<0||a.z<0)
return 0;
if(a.x>=A||a.y>=B||a.z>=C)
return 0;
if(a.time>T)
return 0;
if(v[a.x][a.y][a.z]||map[a.x][a.y][a.z])
return 0;
return 1;
}
void bfs()
{
int i,j,k;
struct s a,temp;
queue<struct s>q;
memset(v,0,sizeof(v));
a.x=a.y=a.z=a.time=0;
v[0][0][0]=1;
q.push(a);
while(!q.empty())
{
a=q.front();
q.pop();
for(i=0;i<6;i++)
{
temp=a;
temp.x+=dx[i];
temp.y+=dy[i];
temp.z+=dz[i];
temp.time++;
if(check(temp))
{
if(temp.x==A-1&&temp.y==B-1&&temp.z==C-1)
{
if(temp.time<ans)
ans=temp.time;
continue;
}
q.push(temp);
v[temp.x][temp.y][temp.z]=1;
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int i,j,k;
scanf("%d%d%d%d",&A,&B,&C,&T);
for(i=0;i<A;i++)
{
for(j=0;j<B;j++)
{
for(k=0;k<C;k++)
scanf("%d",&map[i][j][k]);
}
}
ans=INF;
bfs();
if(ans==INF)
printf("-1\n");
else
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: