您的位置:首页 > 其它

HDU 1985 & ZOJ 2988 Conversions(数学啊)

2015-01-28 18:54 323 查看
题目链接:

HDU: http://acm.hdu.edu.cn/showproblem.php?pid=1985

ZOJ: http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1987

Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:

TypeMetricEnglishequivalent
Weight1.000kilograms2.2046 pounds
Weight0.4536kilograms1.0000 pound
Volume1.0000liter0.2642 gallons
Volume3.7854liters1.0000 gallon
Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds,
liters and gallons respectively.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification
for the converted value.

Sample Input

5

1 kg

2 l

7 lb

3.5 g

0 l

Sample Output

1 2.2046 lb

2 0.5284 g

3 3.1752 kg

4 13.2489 l

5 0.0000 g

代码如下:

#include <cstdio>
#include <cstring>
int main()
{
    int k = 0;
    double n;
    int t;
    char s[3];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%s",&n,s);
        k++;
        printf("%d ",k);
        if(strcmp(s,"kg") == 0)
        {
            printf("%.4lf lb\n",n*2.2046);
        }
        else if(strcmp(s,"l") == 0)
        {
            printf("%.4lf g\n",n*0.2642);
        }
        else if(strcmp(s,"lb") == 0)
        {
            printf("%.4lf kg\n",n*0.4536);
        }
        else if(strcmp(s,"g") == 0)
        {
            printf("%.4lf l\n",n*3.7854);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: