您的位置:首页 > 其它

hdu 1394 逆序数

2015-01-28 10:25 344 查看


Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11995    Accepted Submission(s): 7332


Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)

a2, a3, ..., an, a1 (where m = 1)

a3, a4, ..., an, a1, a2 (where m = 2)

...

an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

 

Output

For each case, output the minimum inversion number on a single line.

 

Sample Input

10
1 3 6 9 0 8 5 7 4 2

 

Sample Output

16

 

Author

CHEN, Gaoli

 

Source

ZOJ Monthly, January 2003

 

Recommend

Ignatius.L

 

 比较简单的题目,先用归并的方法求出初始序列的逆序数cnt,每次将第一个数放到最后,cnt减去小于这个数的数量,再加上大于这个数的数量,答案就是cnt出现过的最小值

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

#define maxn 5005

int a[maxn];
int a1[maxn];
int b[maxn];

int get_inver(int *a, int l, int r)
{
if(l==r) return 0;

int ret = 0;
int m = l+(r-l)/2;

ret += get_inver(a, l, m);
ret += get_inver(a, m+1, r);

int i=l, j=m+1;
int cur = l;
while(cur<=r){
if(i<=m && (a[i]<=a[j]||j>r)){
b[cur++] = a[i++];
ret+=cur-i;
}
else if(j<=r && (a[j]<a[i] || i>m)){
b[cur++] = a[j++];
if(cur>j) ret+=cur-j;
}
}

for(int i = l ; i <= r; i++)
a[i] = b[i];

return ret;
}

int main()
{
int n;
while(scanf("%d", &n)!=EOF){
for(int i = 0; i < n; i++)
scanf("%d", a+i);
memcpy(a1, a, sizeof(a));

int cnt = get_inver(a, 0, n-1);

int ans = cnt;
for(int i = 0; i < n; i++){
cnt-=a1[i];
cnt+=(n-1-a1[i]);
ans=min(ans,cnt);
}

printf("%d\n", ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  逆序数对