您的位置:首页 > 其它

hdu1171 多重背包

2015-01-28 01:57 127 查看
如题:http://acm.hdu.edu.cn/showproblem.php?pid=1171

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).



Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.



Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.



Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1




Sample Output
20 10
40 40


这一题用01背包做过,在我博客里。发我自己的写过的另一种方法的博客链接不能通过审阅?



现在多重背包再写一遍!

直接贴代码

#include<iostream>

#include<cstdio>

#include<cstring>

using namespace std;



int w[55];

int num[55];

int f[50*50*100/2+50];

int N;

#define max(a,b)(a>b?a:b)

int main()

{

while(~scanf("%d",&N)&&N>0)

{

int i,j,k,sum1=0;

memset(f,0,sizeof(f));

for(i=1;i<=N;i++)

{

scanf("%d%d",&w[i],&num[i]);

sum1+=w[i]*num[i];

}

int sum=sum1/2;

for(i=1;i<=N;i++)

{

if(num[i]*w[i]>=sum)

{

for(j=w[i];j<=sum;j++)

f[j]=max(f[j],f[j-w[i]]+w[i]);

}

else

{

int cnt=sum;

k=1;

while(k<=cnt)

{

for(j=sum;j>=k*w[i];j--)

f[j]=max(f[j],f[j-k*w[i]]+k*w[i]);

cnt-=k;

k*=2;

}

for(j=sum;j>=cnt*w[i];j--)

f[j]=max(f[j],f[j-cnt*w[i]]+cnt*w[i]);

}

}

printf("%d %d\n",sum1-f[sum],f[sum]);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: