您的位置:首页 > 其它

HDU-蜗牛爬行问题-有疲劳值

2015-01-27 21:41 190 查看
问题及代码:

/*  
*Copyright (c)2014,烟台大学计算机与控制工程学院  
*All rights reserved.  
*文件名称:HDU.cpp  
*作    者:单昕昕  
*完成日期:2015年1月27日  
*版 本 号:v1.0  
*问题描述:TiA snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day. 

Day Initial Height Distance Climbed Height After Climbing Height After Sliding 
1 0 3 3 2 
2 2 2.7 4.7 3.7 
3 3.7 2.4 6.1 - 

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.
*程序输入:The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.
*程序输出:For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.

Sample Input
6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output
success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2
*/
#include<iostream>
using namespace std;
int main()
{
    double h,u,d,f;
    while(cin>>h>>u>>d>>f&&h!=0)
    {
        double s=0;
        int day=1;
        f=u*f/100;
        while(1)
        {
            s+=u;
            if(s>h)
            {
                cout<<"success on day "<<day<<endl;
                break;
            }
            s-=d;
            if(s<0)
            {
                cout<<"failure on day "<<day<<endl;
                break;
            }
            u-=f;
            if(u<0)
                u=0;
            day++;
        }
    }
    return 0;
}


运行结果:



知识点总结:

根据题目,考虑多种情况。

学习心得:

success:当爬行长度大于深度时。

failure:当出现疲劳损伤后,随着时间推移:

1,上爬长度小于滑下距离后,不能及时的爬出去,导致上爬长度减到0。

2,爬行长度随着下滑而减到0。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: