您的位置:首页 > 其它

ZOJ Problem Set - 1392 The Hardest Problem Ever

2015-01-27 20:05 211 查看
The Hardest Problem Ever

Time Limit: 2 Seconds Memory Limit: 65536 KB

Introduction

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create
one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.

You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e.,
if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:

Cipher text

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text

V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

A single data set has 3 components:

Start line - A single line, "START"

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

End line - A single line, "END"

Following the final data set will be a single line, "ENDOFINPUT".

Output

For each data set, there will be exactly one line of output. This is the original message by Caesar.

Sample Input

START

NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX

END

START

N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ

END

START

IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ

END

ENDOFINPUT

Sample Output

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES

I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME

DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

Source: South Central USA 2002

分析:

题意:

输入多组测试数据。每组测试数据包含三行,第一行是 “START”,不处理;第二行是“END”,也不处理;第三行是一行密码(可能包含空格等多种字符)。要求对大写字母做减5运算(字母表上往左移动五位,其中A~E分别对应V~Z),其他字符不做处理,原样输出就可以。

涉及到有空格等字符的处理,首先想到的就是cin.getline()函数。用这个函数就可以轻松解决这个题了。因为时间方面并没有卡紧。

ac代码:

#include <iostream>

#include<cstdio>

#include<cstring>

#include<string>

using namespace std;

char ss[205];

string s;

int main()

{

int i,j;

while(cin.getline(ss,205))//输入为char

{

s=ss;//转换为string

if(s=="ENDOFINPUT") break;

else if(s=="START") continue;

else if(s=="END") continue;

else

{

for(i=0;i<s.size();i++)

{

if(s[i]>='F'&&s[i]<='Z')

cout<<char(s[i]-5);

else if(s[i]=='A')

cout<<"V";

else if(s[i]=='B')

cout<<"W";

else if(s[i]=='C')

cout<<"X";

else if(s[i]=='D')

cout<<"Y";

else if(s[i]=='E')

cout<<"Z";

else

cout<<s[i];

}

cout<<endl;

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: