您的位置:首页 > 其它

ZOJ Problem Set - 2104 Let the Balloon Rise

2015-01-27 19:06 316 查看
Let the Balloon Rise

Time Limit: 2 Seconds Memory Limit: 65536 KB

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N < 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0

Sample Output

red

pink

Author: WU, Jiazhi

Source: Zhejiang Provincial Programming Contest 2004

分析:
题意:
输入多组测试数据。每组测试数据包含多个字符串(会有重复的),要求输出同种字符串的最大值。

用map处理。map<string,int>就可以轻松解决。
基础题。

ac代码:
#include<iostream>

#include<cstdio>

#include<map>

#include<cstring>

#include<string>

using namespace std;

string s;

map<string,int> m;

int main()

{

int n,i;

while(scanf("%d",&n)&&n)

{

m.clear();

for(i=0;i<n;i++)

{

cin>>s;

m[s]++;

}

int maxn=0;

string ss;

map<string,int>::iterator it;

for(it=m.begin();it!=m.end();it++)

{

if(it->second>maxn)

{

maxn=it->second;

ss=it->first;

}

}

// printf("%s\n",ss);

cout<<ss<<endl;

}

return 0;

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: