您的位置:首页 > 其它

ZOJ Problem Set - 2679 Old Bill

2015-01-27 15:57 281 查看
Old Bill

Time Limit: 2 Seconds Memory Limit: 65536 KB

Among grandfather��s papers a bill was found:

72 turkeys $_679_

The first and the last digits of the number that obviously represented the total price of those turkeys are replaced here by blanks (denoted _), for they are faded and are now illegible. What are the two faded digits and what was the price of one turkey?

We want to write a program that solves a general version of the above problem:

N turkeys $_XYZ_

The total number of turkeys, N, is between 1 and 99, including both. The total price originally consisted of five digits, but we can see only the three digits in the middle. We assume that the first digit is nonzero, that the price of one turkey is an integer
number of dollars, and that all the turkeys cost the same price.

Given N, X, Y , and Z, write a program that guesses the two faded digits and the original price. In case that there is more than one candidate for the original price, the output should be the most expensive one. That is, the program is to report the two faded
digits and the maximum price per turkey for the turkeys.

Input

The input consists of T test cases. The number of test cases (T) is given on the first line of the input file. The first line of each test case contains an integer N (0 < N < 100), which represents the number of turkeys. In the following line, there are the
three decimal digits X, Y , and Z, separated by a space, of the original price $_XYZ_.

Output

For each test case, your program has to do the following. For a test case, there may be more than one candidate for the original price or there is none. In the latter case your program is to report 0. Otherwise, if there is more than one candidate for the original
price, the program is to report the two faded digits and the maximum price per turkey for the turkeys. The following shows sample input and output for three test cases.

Sample Input
3
72
6 7 9
5
2 3 7
78
0 0 5


Sample Output
3 2 511
9 5 18475
0


Source: Asia 2003, Seoul (South Korea)

分析:
题意:
第一行是测试组数T。接下来每一个测试的第一行是整数n,代表火鸡数量;第二行是三个0~9的整数,分别代表第四,第三,第二位数字。要求输出使得火鸡单价最高的完整的五位数(第五位和第一位)和火鸡单价。

简单题。两重for循环遍历就行,从大到小遍历。使用goto跳出双重for循环。

ac代码:
#include<iostream>

#include<cstdio>

using namespace std;

int main()

{

int t,n;

int a,b,c,i,j,k;

int s;

scanf("%d",&t);

while(t--)

{

scanf("%d",&n);

scanf("%d%d%d",&a,&b,&c);

s=a*1000+b*100+c*10;

bool flag=0;

for(i=9;i>=1;i--)

{

for(j=9;j>=0;j--)

{

if((i*10000+s+j)%n==0)

{

printf("%d %d %d\n",i,j,(i*10000+s+j)/n);

goto RL;

}

}

}

printf("0\n");

RL:;

}

return 0;

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: