您的位置:首页 > 大数据 > 人工智能

uva 10780Again Prime? No Time.(简单数论)

2015-01-27 09:36 411 查看
Again Prime? No time.

Input: standard input

Output: standard output

Time Limit: 1 second

The problem statement is very easy. Given a number n you have to determine the largest power of m, not necessarily prime, that divides n!.


Input



The input file consists of several test cases. The first line in the file is the number of cases to handle. The following lines are the cases each of which contains two integers m (1<m<5000) and n
(0<n<10000)
. The integers are separated by an space. There will be no invalid cases given and there are not more that 500 test cases.

Output


For each case in the input, print the case number and result in separate lines. The result is either an integer if mdivides n! or a line "Impossible
to divide
" (without the quotes). Check the sample input and output format.



Sample Input

2

2 10

2 100

Sample Output

Case 1:

8

Case 2:

97



题意:给你m,n求最大的k使得

是n!的因子;

思路:把m质因子分解为

,设p为pi中最大的素数,,然后求n!中p的个数即为

为b,

即为答案(对于i,求出相应的b,

最小的)

代码:

<pre name="code" class="cpp">#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<vector>
#include<stdlib.h>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<set>
#define inf 0x3f3f3f3f
#define eps 1e-5
#define max(a,b) (a)>(b)?(a):(b)
#define min(a,b) (a)<(b)?(a):(b)
using namespace std;
int sum(int n,int p)
{
    int x=p,ans=0;
    while(n/p!=0)
    {
        ans+=n/p;
        p*=x;
    }
    return ans;
}
int main()
{
    int t,n,m,i,j;
    scanf("%d",&t);
    {
        for(i=1;i<=t;i++)
        {
            scanf("%d%d",&m,&n);
            printf("Case %d:\n",i);
            int ans=inf,pnum;
            for(j=2;m>1;j++)
            {
                pnum=0;
                while(m%j==0)
                {
                    pnum++;
                    m/=j;
                }
                if(pnum)
                {
                    int tt=sum(n,j)/pnum;
                    if(ans>tt)ans=tt;
                }
            }
            if(ans)
                printf("%d\n",ans);
            else
                printf("Impossible to divide\n");
        }
    }
    return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: