您的位置:首页 > 其它

LightOJ 1078 - Integer Divisibility(取模运算)

2015-01-27 08:18 417 查看
Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible
by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 andn will not be divisible by
2 or 5) and the allowable digit(1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3

Case 2: 6

Case 3: 12

                                                                                 

题意:

输入n, k,求出n由几个k组成的数整除,求出最少的k的个数。

思路:

取膜运算。加法取膜。

PS:

        

           说明  1. 同余式:正整数a,b对p取模,它们的余数相同,记做 或者a ≡ b (mod p)。
                        2. n % p 得到结果的正负由被除数n决定,与p无关。例如:7%4 = 3, -7%4 = -3, 7%-4 = 3, -7%-4 = -3。

           四则运算 (a + b)%mod = ((a % mod) + (b%mod) ) %mod

                          (a - b) % mod = (a%mod - b%mod)%mod

                          (a*b)%mod = (a%mod*b%mod) % mod

                           (a^b)%mod = ((a%mod)^b)%mod

           结合律 ((a+b) % p + c) % p = (a + (b+c) % p) % p

                        ((a*b) % p * c)% p = (a * (b*c) % p) % p

            交换律 (a + b) % p = (b+a) % p

                         (a * b) % p = (b * a) % p

            分配律 ((a +b)% p * c) % p = ((a * c) % p + (b * c) % p) % p

            重要定理   若a≡b (% p),则对于任意的c,都有(a + c) ≡ (b + c) (%p)

                               若a≡b (% p),则对于任意的c,都有(a * c) ≡ (b * c) (%p)

                               若a≡b (% p),c≡d (% p),则 (a + c) ≡ (b + d) (%p),(a - c) ≡ (b - d) (%p),(a * c) ≡ (b * d) (%p),(a / c) ≡ (b / d) (%p)

CODE:

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
int T;
scanf("%d", &T);
int cas = 0;
while(T--) {
cas++;
int n, k;
scanf("%d %d", &n, &k);
int s = k % n;
int t = 1;
while(s % n) {
s = (s * 10 + k) % n;
t++;
}
printf("Case %d: %d\n", cas, t);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  LightOJ