您的位置:首页 > 其它

ZOJ Problem Set - 1760 Doubles

2015-01-26 23:10 387 查看
Doubles

Time Limit: 2 Seconds Memory Limit: 65536 KB

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how
many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which
is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0

2 4 8 10 0

7 5 11 13 1 3 0

-1



Sample Output


3

2

0

Source: Mid-Central USA 2003

分析:

题意:

给定若干整数,要求输出有几个两倍的关系(就是整数中某个数是另一个数的两倍,就称作有一个两倍关系) 。

简单题。对输入的数排序,然后两重for循环就解决。当然,如果对时间复杂度要求较高,可以使用set集合,查找非常迅速。

ac代码:

#include <iostream>

#include<cstdio>

#include<algorithm>

#include<cstring>

using namespace std;

int a[20];

int main()

{

int j,k;

while(scanf("%d",&a[0])&&a[0]!=-1)

{

int i=0;

int c=0;

while(scanf("%d",&a[++i])&&a[i]!=0)

;

sort(a,a+i+1);

for(j=1;j<=i;j++)

for(k=0;k<j;k++)

if(a[j]==a[k]*2) c++;

/* for(j=1;j<=i;j++)//测试

{

printf("%d ",a[j]);

}*/

printf("%d\n",c);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: