您的位置:首页 > 大数据 > 人工智能

ZOJ Problem Set - 2201 No Brainer

2015-01-26 10:55 183 查看
No Brainer

Time Limit: 2 Seconds Memory Limit: 65536 KB

Zombies love to eat brains. Yum.
Input
The first line contains a single integer n indicating the number of data sets.
The following n lines each represent a data set. Each data set will be formatted according to the following description:
A single data set consists of a line "X Y", where X is the number of brains the zombie eats and Y is the number of brains the zombie
requires to stay alive.
Output
For each data set, there will be exactly one line of output. This line will be "MMM BRAINS" if the number of brains the zombie eats is greater than or equal to the number of brains the
zombie requires to stay alive. Otherwise, the line will be "NO BRAINS".
Sample Input
3

4 5

3 3

4 3

Sample Output
NO BRAINS

MMM BRAINS

MMM BRAINS

Source: South Central USA 2004

分析:

题意:

给定多组测试数据。每组测试数据有两个数n和m,如果n>=m,输出“MMM BRAINS” ;否则,输出”NO BRAINS“.

水题。

ac代码:

#include<iostream>

#include<cstdio>

using namespace std;

int main()

{

int n,m,t;

scanf("%d",&t);

while(t--)

{

scanf("%d%d",&n,&m);

if(n>=m)

printf("MMM BRAINS\n");

else printf("NO BRAINS\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: