您的位置:首页 > 其它

2015寒假集训周赛第一场 A题

2015-01-24 15:38 274 查看
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd

aaaa

ababab

.

Sample Output

1

4

3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

#include <stdio.h>
#include <string.h>
#include <algorithm>
char a[55555556];
int main()
{
int i,j,len;
while(~scanf("%s",a),a[0]!='.')
{
int flag;
len=strlen(a);
for(i=1; i<=len; i++)
{
flag=1;
if(len%i==0)
{
for(j=i; j<len; j++)
{
if(a[j]!=a[j%i])
{
flag=0;
break;
}
}
if(flag==1)
{
break;
}
}
}
printf("%d\n",len/i);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: