您的位置:首页 > 其它

SDUT_OJ_1464-链表-删除指定元素

2015-01-23 21:30 337 查看

题目描述

对于一个给定的线性表,要求删除线性表内的大于等于 min 且小于等于 max 的数,并输出删除后的线性表

要求:必须使用链表做,否则不计成绩!

输入

输入的第一行为一个正整数 T,表示有 T 组测试数据。

每组测试数据的第一行为三个整数n、min、max,表示有 n 个数据,删除的范围为[min, max].第二行为 n 个整数代表初始的 n 个数据。

输出

输出删除数据后的线性表,如果线性表为空则输出-1

示例输入

2
3 1 2
1 2 3
5 2 1
1 1 1 1 1


示例输出

3
1 1 1 1 1

代码

#include <iostream>
#include <stdlib.h>

using namespace std;

struct node
{
int data;
struct node* next;
};

int a[10000];

int main()
{
ios::sync_with_stdio(false);
int t,n,min,max,i;
struct node*p,*head,*q,*tail;

cin>>t;
while(t--)
{
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
cin>>n>>min>>max;
for(i=0; i<n; i++)
{
p=(struct node*)malloc(sizeof(struct node));
cin>>p->data;
p->next=NULL;
tail->next=p;
tail=p;
}
p=head;
while(p->next!=NULL)
{
if(p->next->data>=min&&p->next->data<=max)
{
q=p->next;
p->next=q->next;
free(q);
}
else
p=p->next;
}
p=head->next;
if(p==NULL)
cout<<-1<<endl;
else
{
while(p!=NULL)
{
cout<<p->data;
p=p->next;
if(p!=NULL) cout<<' ';
else cout<<endl;
}
}
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: