您的位置:首页 > 其它

HDU 2069 Coin Change (经典DP)

2015-01-23 18:43 519 查看

Coin Change

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14500 Accepted Submission(s): 4879


[align=left]Problem Description[/align]
Suppose
there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and
1-cent. We want to make changes with these coins for a given amount of
money.

For example, if we have 11 cents, then we can make changes
with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one
1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent
coins. So there are four ways of making changes for 11 cents with the
above coins. Note that we count that there is one way of making change
for zero cent.

Write a program to find the total number of
different ways of making changes for any amount of money in cents. Your
program should be able to handle up to 100 coins.

[align=left]Input[/align]
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

[align=left]Output[/align]
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

[align=left]Sample Input[/align]

11

26

[align=left]Sample Output[/align]

4

13
题意:有1,5,10,25,50这五种硬币,给出一个数N,求用这些硬币能组成N的方法有几种。

分析:这题数据比较水,用暴力法能过,但是我尝试了很多方式的DP,WA或者超时,还在研究中。。。。

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
int main()
{
int n,a,b,c,d,e,count;
while(~scanf("%d",&n))
{
count=0;
for(a=0;a<=n;a++)
{
for(b=0;5*b<=n-a;b++)
{
for(c=0;10*c<=n-a-5*b;c++)
{
for(d=0;25*d<=n-a-5*b-10*c;d++)
{
e=n-a-5*b-10*c-25*d;
if(e%50==0 && a+b+c+d+e/50<=100)
count++;
}
}
}
}
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: