您的位置:首页 > 其它

POJ 1731 Orders(带重复字母的全排列 + 暴力)

2015-01-23 15:16 369 查看

POJ 1731 Orders

Description

The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this
letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.

You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece
during the day.

Input

Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders
doesn't exceed 200.

Output

Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods.
Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes.

Sample Input

bbjd


Sample Output

bbdj
bbjdbdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb


题目大意:给出一串字符串,要求输出其不重复的全排列,要求起全排列从小到大。

解题思路:因为输出的全排列要求从小到大,所以先对起始字符串进行排序,之后用递归和DFS的思想输出其全排列序列。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int vis[205], len;
char ch[205], temp[205];
void print(int cnt) {
	char c = 0;
	if (cnt == len) { 
		printf("%s\n", temp);
		return;
	}
	for (int i = 0; i < len; i++) {
		if (!vis[i] && c != ch[i]) {    //实现不重复输出同一节点,并对不同的相同值节点进行处理
			temp[cnt] = ch[i];
			c = temp[cnt];
			vis[i] = 1;  //标记  正在访问
			print(cnt + 1);
			vis[i] = 0;  //释放
		}
	}
}
int main() {
	memset(ch, 0, sizeof(ch));
	memset(temp, 0, sizeof(temp));
	memset(vis, 0, sizeof(vis));
	scanf("%s", ch);
	len = strlen(ch);
	sort(ch, ch + len);
	print(0);	
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: