您的位置:首页 > 其它

HDU 1258 Sum It Up

2015-01-21 22:37 387 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1258

Sum It Up

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4352 Accepted Submission(s): 2245



Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2,
and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.



Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise,
t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order,
and there may be repetitions.



Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order.
A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums
with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.



Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0




Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


给你n个数问你有多少方式可以凑成t

关键是如何去掉重复的情况。

下面是AC代码

#include<iostream>
using namespace std;
int n,t,ans[15],a[15];
bool flag;
void dfs(int d,int sum,int cnt)
{
    if(sum>t) return ;
    if(sum==t)
    {
        flag=1;
        for(int i=0;i<cnt-1;i++) cout<<ans[i]<<"+";
        cout<<ans[cnt-1]<<endl;
        return ;
    }
    int temp=-1;
    for(int i=d;i<n;i++)
    {
        if(temp!=a[i])
        {
            temp=a[i];
            ans[cnt]=a[i];
            dfs(i+1,sum+a[i],cnt+1);
        }
    }
}
int main()
{
    while(cin>>t>>n&&n)
    {
        cout<<"Sums of "<<t<<":"<<endl;
        for(int i=0;i<n;i++) cin>>a[i];
        flag=0;
        dfs(0,0,0);
        if(!flag) cout<<"NONE"<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: