您的位置:首页 > 其它

ZOJ Problem Set - 1151 Word Reversal

2015-01-21 21:07 176 查看
Word Reversal

Time Limit: 2 Seconds Memory Limit: 65536 KB

For each list of words, output a line with each word reversed without changing the order of the words.

This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank
line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words
separated by one space, and each word contains only uppercase and lowercase letters.

Output
For each test case, print the output on one line.

Sample Input
1
3

I am happy today

To be or not to be

I want to win the practice contest

Sample Output
I ma yppah yadot

oT eb ro ton ot eb

I tnaw ot niw eht ecitcarp tsetnoc

Source: East Central North America 1999, Practice

分析:

题目很简单,坑就坑在字符串的处理上。而且感觉题意也不清楚。但无论如何作为一个加强对字符串处理理解的问题,还是有一定价值的。

题意:

给定若干字符串(分块),输出它们的反串(反过来)。

ac代码:

//scanf()是无法判断读入的是不是空格,换行之类符号的

//这里应该是认为单词之间必定有空格,即没有一行只有一个单词的情况

#include <iostream>

#include<cstdio>

#include<cstring>

#include<string>

using namespace std;

char c[100];

string s,ss;

int main()

{

int n,m,i;

cin.getline(c,5);//不处理块数量,这里同时也把下一行的换行读取了

cin.getline(c,5);//不处理第一块的行数量

bool flag=1;

while(cin.getline(c,100))

{

s=c;

//int L=s.size();

if(s.find(' ')==2147483647*2+1&&!flag)//是行数量又不是第一块.这里应该是认为单词之间必定有空格,即没有一行只有一个单词的情况

{

cin.getline(c,5);

cout<<endl;

}

else flag=0;

if(s.find(' ')!=2147483647*2+1)//这里应该是认为单词之间必定有空格,即没有一行只有一个单词的情况

{

int L=s.size();

for(i=0;i<L;i++)

{

if(s[i]!=' ')

ss=s[i]+ss;

else

{

cout<<ss<<" ";

ss="";

}

}

cout<<ss<<endl;

ss="";

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: