您的位置:首页 > 其它

ZOJ Problem Set - 2932 The Seven Percent Solution

2015-01-20 22:50 393 查看
The Seven Percent Solution

Time Limit: 2 Seconds Memory Limit: 65536 KB

Uniform Resource Identifiers (or URIs) are strings like http://icpc.baylor.edu/icpc/, mailto:foo@bar.org, ftp://127.0.0.1/pub/linux, or even just readme.txt that
are used to identify a resource, usually on the Internet or a local computer. Certain characters are reserved within URIs, and if a reserved character is part of an identifier then it must be percent-encoded by replacing it with a percent sign followed
by two hexadecimal digits representing the ASCII code of the character. A table of seven reserved characters and their encodings is shown below. Your job is to write a program that can percent-encode a string of characters.
CharacterEncoding
" " (space)%20
"!" (exclamation point)%21
"$" (dollar sign)%24
"%" (percent sign)%25
"(" (left parenthesis)%28
")" (right parenthesis)%29
"*" (asterisk)%2a
Input
The input consists of one or more strings, each 1-79 characters long and on a line by itself, followed by a line containing only "#" that signals the end of the input. The character "#"
is used only as an end-of-input marker and will not appear anywhere else in the input. A string may contain spaces, but not at the beginning or end of the string, and there will never be two or more consecutive spaces.
Output
For each input string, replace every occurrence of a reserved character in the table above by its percent-encoding, exactly as shown, and output the resulting string on a line by itself.
Note that the percent-encoding for an asterisk is %2a (with a lowercase "a") rather than %2A (with an uppercase "A").
Sample Input
Happy Joy Joy! http://icpc.baylor.edu/icpc/ plain_vanilla
(**)
?
the 7% solution
#

Sample Output
Happy%20Joy%20Joy%21 http://icpc.baylor.edu/icpc/ plain_vanilla
%28%2a%2a%29
?
the%207%25%20solution


Source: The 2007 ACM Mid-Central USA Programming Contest

分析:

根据表格替换字符的水题。

还是cin.getline()的使用,还有注意转义字符就可以了。

ac代码:

#include <iostream>

#include<cstdio>

#include<cstring>

#include<string>

using namespace std;

char a[80];

int main()

{

int i;

while(cin.getline(a,80)&&a[0]!='#')

{

for(i=0;a[i]!='\0';i++)

{

if(a[i]==' ')

printf("%%20");//这里要用转义字符,%%20才能输出%20

else if(a[i]=='!')

printf("%%21");

else if(a[i]=='$')

printf("%%24");

else if(a[i]=='%')//这里的%只是作为一个字符,不用转义字符

printf("%%25");

else if(a[i]=='(')

printf("%%28");

else if(a[i]==')')

printf("%%29");

else if(a[i]=='*')

printf("%%2a");

else

printf("%c",a[i]);

}

printf("\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: