您的位置:首页 > 其它

ZOJ Problem Set - 2886 Look and Say

2015-01-20 21:50 323 查看
Look and Say

Time Limit: 2 Seconds Memory Limit: 65536 KB

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally"
describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111.
Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.
Input
The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.
Output
For each test case, print the string that follows the given string.
Sample Input

3

122344111

1111111111

12345

Sample Output

1122132431

101

1112131415

Source: The 2007 ACM Rocky Mountain Programming Contest

分析:

与zoj2478题”Encoding“(编码问题)一模一样,无非就是把字符串改成了数字,但数字还是用字符串处理的,代码几乎没改。

ac代码:

#include <iostream>

#include<cstdio>

#include<cstring>

#include<string>

using namespace std;

char c;

string s;

int main()

{

int n,i,j,num;

scanf("%d",&n);

while(n--)

{

cin>>s;

int L=s.size();

c=s[0];

num=0;

for(i=0;i<L;i++)

{

if(c==s[i])

{

num++;

if(i==L-1)//最后一个要直接输出,因为for循环已经终止了

{

//if(num==1)

//cout<<c;

//else

printf("%d%c",num,c);

}

}

else

{

printf("%d%c",num,c);

c=s[i];

num=1;//注意是从1开始计数,因为已经有一个是不同的

if(i==L-1)//最后一个要直接输出,因为for循环已经终止了

printf("%d%c",num,c);

}

}

printf("\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: