您的位置:首页 > 产品设计 > UI/UE

ZOJ Problem Set - 2812 Quicksum

2015-01-20 16:19 337 查看
Quicksum

Time Limit: 2 Seconds Memory Limit: 65536 KB

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used
for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.
For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter.
Otherwise, spaces and letters can occur in any combination, including consecutive spaces.
A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position
in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":
ACM: 1*1  + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input: The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not
begin or end with a space, and contains from 1 to 255 characters.
Output: For each packet, output its Quicksum on a separate line in the output.
Example Input:Example Output:
ACM

MID CENTRAL

REGIONAL PROGRAMMING CONTEST

ACN

A C M

ABC

BBC

#
46

650

4690

49

75

14

15
Source: Mid-Central USA 2006

分析:

题目本身非常简单,就是套公式。

主要用来训练字符串的读写操作(空格,换行,Tab跳格等特殊字符的处理)

方法一:

cin.get()版本:字符一个一个读入

#include <iostream>

#include<cstdio>

#include<fstream>

using namespace std;

int main()

{

//ifstream cin("D:\\abc.txt");//本机测试

char ch;

int i=1,s=0;

while(cin.get(ch)&&ch!='#') //cin.get()不会忽略任何字符

{

if(ch!='\n')

{

if(ch!=' ')

s+=i*(ch-64);

i++;

}

else

{

printf("%d\n",s);

s=0;

i=1;

}

}

return 0;

}

方法二:

cin.getline()版本:一次读入一行

//cin.getline(char* cha,int num,char f);

//向cha中输入num个字符,输入过程中达到num个数或者提前遇到f字符,输入结束。

#include <iostream>

#include<cstdio>

#include<fstream>

using namespace std;

int main()

{

//ifstream cin("D:\\abc.txt");//本机测试

char ch[2<<8];

int i=1,s=0;

while(cin.getline(ch,2<<8)&&ch[0]!='#')

{

for(i=0;ch[i]!='\0';i++)//'\0'是C++中字符串的结尾标志,存储在字符串的结尾。

{

if(ch[i]!=' ')

s+=(i+1)*(ch[i]-64);

}

printf("%d\n",s);

s=0;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: