您的位置:首页 > 其它

HDU 1073 Online Judge

2015-01-20 10:55 387 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1073

Online Judge

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5631 Accepted Submission(s): 2130



Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files
are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.



Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data.
In other words, the data is between the two strings. The data will at most 5000 characters.



Output
For each test cases, you should output the the result Judge System should return.



Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1	+	2	=	3
END




Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error


就是叫你写一个OJ后台的评测程序,能够判断AC,WA,PE。

把输入文件和输出文件分别都拼接到同一个字符串上去。然后如果相同则AC,

如果不相同。则把两个字符串的回车、空格、制表符都去了,此时如果相同则判PE。否则WA

下面是AC代码

#include<iostream>
#include<algorithm>
using namespace std;
string getString(string s)
{
    string ans;
    for(int i=0;i<s.size();i++)
        if(s[i]!=' '&&s[i]!='\t'&&s[i]!='\n') ans+=s[i];
    return ans;
}
bool judge(string a,string b)
{
    string na=getString(a),nb=getString(b);
    if(na==nb) return 1;
    return 0;
}
int main()
{
    string s;
    int t;
    cin>>t;
    getline(cin,s);
    while(t--)
    {
        string a,b;
        getline(cin,s);
        while(getline(cin,s)&&s!="END") a+=s+'\n';
        getline(cin,s);
        while(getline(cin,s)&&s!="END") b+=s+'\n';
        if(a==b) cout<<"Accepted"<<endl;
        else if(judge(a,b)) cout<<"Presentation Error"<<endl;
        else cout<<"Wrong Answer"<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: