您的位置:首页 > 其它

hdu3555--Bomb(数位dp练习3)

2015-01-20 10:49 711 查看
Bomb
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the
power of the blast would add one point. 

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 

 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 

 

Output

For each test case, output an integer indicating the final points of the power.
 

Sample Input

 3
1
50
500

 

Sample Output

 0
1
15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.


求1到n中不含49的数的个数

dp[i][j][0]代表i位的数,最高位为j时,没有出现49的个数

dp[i][j][1]代表i位的数,最高位为j时,出现49的个数

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define LL __int64
LL dp[25][10][2] ;
int digit[25] , cnt ;
void init()
{
int i , j , k ;
memset(dp,0,sizeof(dp)) ;
for(j = 0 ; j < 10 ; j++)
dp[1][j][0] = 1 ;
for(i = 2 ; i <= 20 ; i++)
{
for(j = 0 ; j < 10 ; j++)
{
for(k = 0 ; k < 10 ; k++)
{
dp[i][j][1] += dp[i-1][k][1] ;
if( j == 4 && k == 9 )
dp[i][j][1] += dp[i-1][k][0] ;
else
dp[i][j][0] += dp[i-1][k][0] ;
}
//printf("dp[%d][%d] %I64d %I64d\n", i , j , dp[i][j][0], dp[i][j][1]) ;
}
}
return ;
}
LL solve(LL temp)
{
int flag , i , j ;
LL ans = 0 ;
memset(digit,0,sizeof(digit)) ;
cnt = 0 ;
while( temp )
{
digit[++cnt] = temp % 10 ;
temp /= 10 ;
}
for(j = 0 ; j < digit[cnt] ; j++)
ans += dp[cnt][j][1] ;
flag = 0 ;
for(i = cnt-1 ; i > 0 ; i--)
{
for(j = 0 ; j < digit[i] ; j++)
{
ans += dp[i][j][1] ;
if( flag )
ans += dp[i][j][0] ;
}
if( digit[i+1] == 4 && digit[i] == 9 )
flag = 1 ;
}
return ans ;
}
int main()
{
LL t , n , ans ;
init() ;
scanf("%I64d", &t) ;
while( t-- )
{
scanf("%I64d", &n) ;
ans = solve(n+1) ;
printf("%I64d\n", ans) ;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: