您的位置:首页 > 其它

UVa 1586 / UVALive 3900 Molar mass (字符串)

2015-01-18 17:51 411 查看
Molar mass

Time Limit: 3000MSMemory Limit: Unknown64bit IO Format: %lld & %llu
Submit Status

Description





An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.



When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3H4O3 , identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.

In this problem, we assume that the molecular formula is represented by only four elements, `C' (Carbon), `H' (Hydrogen), `O' (Oxygen), and `N' (Nitrogen) without parentheses.

The following table shows that the standard atomic weights for `C', `H', `O', and `N'.

Atomic NameCarbonHydrogenOxygenNitrogen
Standard Atomic Weight12.01 g/mol1.008 g/mol16.00 g/mol14.01 g/mol
For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by 6 ×
(12.01 g/mol) + 6 ×
(1.008 g/mol) + 1 ×
(16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T
is given in the first line of the input. Each test case is given in a
single line, which contains a molecular formula as a string. The
chemical symbol is given by a capital letter and the length of the
string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2

n

99)
.

Output

Your program is to write to standard output. Print exactly one line for
each test case. The line should contain the molar mass of the given
molecular formula.

Sample Input

4
C
C6H5OH
NH2CH2COOH
C12H22O11

Sample Output

12.010
94.108
75.070
342.296
大致题意:给出一种物质的分子式(不带括号),求分子量。这题中的分子式只含有4种原子,分别为C、O、H、N,原子量分别为12.01、16.00、1.008、14.01(单位:g/mol)。


#include<cstdio>
#include<cstring>
#include<cctype>
double ch(char mol)
{
switch (mol)
{
case 'C': return 12.01;
case 'H': return 1.008;
case 'O': return 16.00;
case 'N': return 14.01;
}
return 0.0;
}
int main()
{
int T;
char str[100];
scanf("%d\n",&T);
while(T--)
{
gets(str);
double count=0.0;
int len=strlen(str);
int npos=0;
while (npos<len)
{
double num=ch(str[npos]);
double sum=num;
if (npos+1<len && isdigit(str[npos+1]))
sum *= str[++npos]-'0';
if (npos+1<len && isdigit(str[npos+1]))
sum = (sum*10 + num*(str[++npos]-'0'));
npos++;
count+= sum;
}
printf("%.3f\n",count);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: