您的位置:首页 > 其它

HDOJ 题目2662 Coin(数学)

2015-01-12 11:11 369 查看


Coin

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 735    Accepted Submission(s): 365


Problem Description

Moon has many coins, but only contains two value types which is 5 cents and 7 cents, Some day he find that he can get any value which greater than 23 cents using some of his coins. For instance, he can get 24 cents using two 5 cents coins and two 7 cents coins,
he can get 25 cents using five 5 cents coins, he can get 26 cents using one 5 cents coins and three 7 cents coins and so on. 

Now, give you many coins which just contains two value types just like Moon, and the two value types identified by two different prime number i and j. Can you caculate the integer n that any value greater than n can be created by some of the given coins.

 

Input

The first line contains an integer T, indicates the number of test cases. 

For each test case, there are two different prime i and j separated by a single space.(2<=i<=1000000, 2<=j<=1000000)

 

Output

For each test case, output one line contains the number n adapt the problem description.

 

Sample Input

1
5 7

 

Sample Output

23

 

Source

HDU男生专场公开赛——赶在女生之前先过节(From
WHU)

 

Recommend

zty   |   We have carefully selected several similar problems for you:  2661 2665 2663 2667 2666 

 题目大概意思是给你两种硬币,各种组合,超过一个数后的所有数都能用这两种硬币表示,让你求最小的这个数,

这种题不看别人的代码,试了好久都试不出规律,哎,,,太菜了,当个规律记下吧先

别人的推导思路:

出几组数据就可以猜到a*b-a-b,不过这里还是证明一下吧。

设所求为n,那么n+a、n+b可以用a、b线性表出,而n不可。

所以 n+a=x1*a+y1*b,n+b=x2*a+y2*b

所以 n=(x1-1)*a+y1*b n=x2*a+(y2-1)*b

因为n不能被线性表出,所以x1=0,y2=0

所以 n+a=y1*b,n+b=x2*a

所以 n+a=y1*b,n+a=(x2+1)*a-b

所以 (x2+1)*a-b是b的倍数

因为a、b互质,所以(x2+1)是b的倍数

因为求最小的n,所以选最小的x2值,所以取(x2+1)为b

所以 n+a=b*a-b,n=a*b-a-b

证毕

ac代码

(不用64位会wa)

#include<stdio.h>
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
__int64 a,b;
scanf("%I64d%I64d",&a,&b);
printf("%I64d\n",a*b-a-b);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: