您的位置:首页 > 其它

poj 1915 Knight Moves

2015-01-11 17:29 302 查看
Default

Knight Moves

Description

Background

Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?

The Problem

Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.

For people not familiar with chess, the possible knight moves are shown in Figure 1.



Input

The input begins with the number n of scenarios on a single line by itself.

Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers
{0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a
single line.
Sample Input
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output
5
28
0

简单的bfs.
具体实现如下:

#define  _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 300 + 2
#define INF 0x7fffff
typedef struct node
{
	int x, y;
}Node;
Node Queue[100000], cur, now;
int table

, Dirct

;
void Init()
{
	memset(table, 0, sizeof(table));
	memset(Queue, 0, sizeof(Queue));
}
void bfs(int size, int Sx, int Sy, int Dx, int Dy)
{
	int i, j, nx, ny, rear = 0, front = 0;
	int dx[8] = { 1, 2, 1, 2, -1, -2, -1, -2 };
	int dy[8] = { -2, -1, 2, 1, 2, 1, -2, -1 };
	for (i = 0; i < size; i++)
	{
		for (j = 0; j < size; j++)
			Dirct[i][j] = INF;
	}
	now.x = Sx, now.y = Sy;
	Queue[rear++] = now;
	Dirct[Sx][Sy] = 0;
	while (front < rear)
	{
		now = Queue[front++];
		if (now.x == Dx && now.y == Dy)
			break;
		for (i = 0; i < 8; i++)
		{
			nx = now.x + dx[i], ny = now.y + dy[i];
			if (nx >= 0 && nx < size && ny >= 0 && ny < size && INF == Dirct[nx][ny])
			{
				Dirct[nx][ny] = Dirct[now.x][now.y] + 1;
				cur.x = nx, cur.y = ny;
				Queue[rear++] = cur;
			}
		}
	}
	printf("%d\n", Dirct[Dx][Dy]);
}
void solve()
{
	Init();
	int size, Dx, Dy, Sx, Sy;
	scanf("%d %d %d %d %d", &size, &Sx, &Sy, &Dx, &Dy);
	bfs(size, Sx, Sy, Dx, Dy);
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
		solve();
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: