您的位置:首页 > 其它

【HDU 5088】Revenge of Nim II

2015-01-11 12:26 471 查看


Revenge of Nim II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 522 Accepted Submission(s): 188



Problem Description

Nim is a mathematical game of strategy in which two players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

---Wikipedia

Today, Nim takes revenge on you, again. As you know, the rule of Nim game is rather unfair, only the nim-sum (⊕) of the sizes of the heaps is zero will the first player lose. To ensure the fairness of the game, the second player has a chance to move some (can
be zero) heaps before the game starts, but he has to move one heap entirely, i.e. not partially. Of course, he can’t move all heaps out, at least one heap should be left for playing. Will the second player have the chance to win this time?

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the number of heaps. Then N integer Ai follows, indicating the number of each heap.

[Technical Specification]

1. 1 <= T <= 100

2. 1 <= N <= 1 000

3. 1 <= Ai <= 1 000 000 000 000

Output

For each test case, output “Yes” if the second player can win by moving some (can be zero) heaps out, otherwise “No”.

Sample Input

3
1
2
3
2 2 2
5
1 2 3 4 5


Sample Output

No
Yes
Yes
HintFor the third test case, the second player can move heaps with 4 and 5 objects out, so the nim-sum of the sizes of the left heaps is 1⊕2⊕3 = 0.


Source

BestCoder Round #16

Recommend

heyang | We have carefully selected several similar problems for you: 5161 5160 5159 5158 5157

高斯消元后判断是否存在0的项。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
#define LL long long
using namespace std;
int T,n,now;
LL a[1005];
void Gauss()
{
now=1;
int m=50;
while (m--)
{
for (int i=now;i<=n;i++)
if ((1LL<<m)&a[i])
{
swap(a[now],a[i]);
for (int j=1;j<=n;j++)
if (j!=now&&(1LL<<m)&a[j]) a[j]^=a[now];
now++;
break;
}
}
now--;
}
int main()
{
scanf("%d",&T);
while (T--)
{
scanf("%d",&n);
for (int i=1;i<=n;i++)
scanf("%lld",&a[i]);
Gauss();
if (now==n) printf("No\n");
else printf("Yes\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: