您的位置:首页 > 运维架构

LightOJ - 1001 Opposite Task

2015-01-10 22:37 148 查看
Description

This problem gives you a flavor the concept of special judge. That means the judge is smart enough to verify your code even though it may print different results. In this problem you are asked to find the opposite task of the previous problem.

To be specific, I have two computers where I stored my problems. Now I know the total number of problems is n. And there are no duplicate problems and there can be at most 10 problems in each computer. You have to find the
number of problems in each of the computers.

Since there can be multiple solutions. Any valid solution will do.

Input

Input starts with an integer T (≤ 25), denoting the number of test cases.

Each case starts with a line containing an integer n (0 ≤ n ≤ 20) denoting the total number of problems.

Output

For each case, print the number of problems stored in each computer in a single line. A single space should separate the non-negative integers.

Sample Input

3

10

7

7

Sample Output

0 10

0 7

1 6

题目的sample output貌似有问题,不过我这个提交就可以了,根据题意和输出大概意思是 b是先解决问题,如果b的解决问题大于10,就给a 10道,剩下给b

#include <iostream>

using namespace std;

int main(){
int T;
while(cin>>T){
while(T--){
int num;
cin>>num;
int a = 0, b = num;
if(num > 10){
a = 10; b = num-10;
}
cout<<a<<" "<<b<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: