您的位置:首页 > 其它

Pat(Advanced Level)Practice--1084(Broken Keyboard)

2015-01-09 23:20 495 查看

Pat1084代码

题目描述:

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital
numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:
7_This_is_a_test
_hs_s_a_es

Sample Output:
7TI


AC代码:
#include<cstdio>
#include<cstdlib>
#include<map>
#define MAXN 100

using namespace std;

void featureNormalize(char str[]){
for(int i=0;str[i]!='\0';i++){
if(str[i]>='a'&&str[i]<='z'){
str[i]=str[i]-'a'+'A';
}
}
}

int main(int argc,char *argv[]){
char stdInput[MAXN];
char factInput[MAXN];
map<char,int> m;
scanf("%s",stdInput);
scanf("%s",factInput);
featureNormalize(stdInput);
featureNormalize(factInput);
for(int i=0;factInput[i]!='\0';i++){
char key=factInput[i];
m[key]++;
}
for(int i=0;stdInput[i]!='\0';i++){
char key=stdInput[i];
if(m[key]==0){
printf("%c",key);
m[key]++;
}
}
printf("\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Advance pat map