您的位置:首页 > 其它

hoj 1015 Nearly prime numbers

2015-01-09 00:52 459 查看


Nearly prime numbers

My Tags (Edit)
Source : Unknown
Time limit : 1 secMemory limit : 1 M
Submitted : 5032, Accepted : 888

Nearly prime number is an integer positive number for which it is possible to find such primes P1 and P2 that
given number is equal toP1*P2. There is given a sequence on N integer positive numbers,
you are to write a program that prints Yes if given number is nearly prime and No otherwise.
Input

Input consists of N+1 numbers. First is positive integer N (1<=N<=50000). Next N numbers followed by N.
Each number is not greater than 109. All numbers separated by whitespace(s).
Output

Write a line in output for each number of given sequence. Write Yes if given number is nearly prime and No in other case.
Sample Input
1
6

Sample Output
Yes

题意是:问一个数能否化成两个素数的乘积。
可以先用筛选法处理前40000个素数,再比较可知、
坑点是什么。用c++的话,iostream 就直接超内存了
一定要用stdio



#include <stdio.h>

using namespace std;

int prime[35000];

bool isprime(int a)

{

if(a<2) return false;

for(int i=2;i*i<=a;i++)

{

if(a%i==0) return false;

}

return true;

}

int main()

{

int t;

scanf("%d",&t);

int top=0;

for(int i=2;i<=35000;i++) if(isprime(i)==1) {prime[top]=i;top++;}

while(t--)

{

int n;

scanf("%d",&n);

int flag=0;

for(int i=0;i<top;i++)

{

if(n%prime[i]==0&&isprime(n/prime[i]))

{

flag=1;

printf("Yes\n");

break;

}

}

if(flag==0) printf("No\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: