您的位置:首页 > 其它

POJ 题目2356 Find a multiple(鸽巢原理)

2015-01-08 17:46 567 查看
Find a multiple

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6326 Accepted: 2760 Special Judge
Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of
given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).
Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.
Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate
line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.
Sample Input
5
1
2
3
4
1

Sample Output
2
2
3

Source
Ural Collegiate Programming Contest 1999
ac代码
实际上不加break也能过。。
#include<stdio.h>
#include<string.h>
int sum[10010],a[10010],v[10010];
int main()
{
int n;
int i,l,r;

scanf("%d",&n);
sum[0]=0;
memset(v,-1,sizeof(v));
v[0]=0;//注意
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum[i]=(sum[i-1]+a[i])%n;
if(v[sum[i]]==-1)
v[sum[i]]=i;
else
{
l=v[sum[i]];
r=i;
break;
}
}
printf("%d\n",r-l);
for(i=l+1;i<=r;i++)
printf("%d\n",a[i]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: