您的位置:首页 > 其它

a letter and a number

2015-01-05 22:40 302 查看


a letter and a number

时间限制:3000 ms | 内存限制:65535 KB
难度:1

描述we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

输入On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3


样例输出
19
18
10
-17
-14
-4


上传者
苗栋栋

01.
#include<stdio.h>


02.
int
main()


03.
{


04.
int
i,N,k,a[10001]={0},b[10001]={0};


05.
scanf
(
"%d"
,&N);


06.
getchar
();


07.
for
(i=0;i<N;i++)


08.
{


09.
scanf
(
"%c%d"
,&a[i],&b[i]);


10.
getchar
();


11.
}


12.


13.
for
(i=0;i<N;i++)


14.
{


15.
if
(a[i]>=97)


16.
a[i]=96-a[i];


17.
else


18.
a[i]=a[i]-64;


19.
printf
(
"%d\n"
,a[i]+b[i]);


20.
}


21.
return
0;


22.


23.
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: