您的位置:首页 > 其它

poj 3280 Cheapest Palindrome(区间dp)

2015-01-05 20:52 232 查看
题目链接

Cheapest Palindrome

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 6117Accepted: 2981
Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of
N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤
cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so
it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input
Line 1: Two space-separated integers: N and
M

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

Hint
If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 +
350 = 900, which is the minimum.

题意:给一个字符串由小写字母组成,告诉你添加和删除一个字母的花费,可以在串的任意位置添加字母。问吧该串变成回文串的最小花费?

题解:考虑让字符串变成回文串。我们优先处理首尾的两个字符。

如果首尾的两个字符相等,那么就让这两个字符作为最后回文串的首尾的字符,它们不在对其它字符产生影响,问题就变成了除开首尾的字符,让剩下的字符串变成回文的最小花费。

如果首尾的字符不相等,我们可以添加一个首字符在字符串的末尾或者删除首字符,剩下的问题就是除开首字符,让剩下的字符串变成回文的最小花费。当然,我们也可以添加一尾字符在字符串的开头或者删除尾字符,剩下的问题就除开尾字符,让剩下的字符串变成回文串的最小花费。

由于每次我们只操作首尾的字符,所以可以用区间dp来做。

用dp[l][r]表示把区间[l,r]的串变成回文串的最小花费。那么转移就是:

if(s[l]==s[r])

dp[l][r]=dp[l+1][r-1];

dp[l][r]=min(dp[l+1][r]+cost(l),dp[l][r-1]+cost(r)).

cost(x)为在x位置的字符串的对面添加一个字符或删除位置x的字符的最小花费。

代码如下:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<string>
#include<math.h>
#define nn 2100
#define inff 0x7fffffff
#define eps 1e-8
typedef long long LL;
const LL inf64=LL(inff)*inff;
using namespace std;
int n,m;
int cost[30];
char s[nn];
char sr[10];
int dp[nn][nn];
int dfs(int l,int r)
{
if(l>r)
return 0;
if(dp[l][r]!=-1)
return dp[l][r];
if(l==r)
return dp[l][r]=0;
dp[l][r]=inff;
if(s[l]==s[r])
dp[l][r]=min(dp[l][r],dfs(l+1,r-1));
dp[l][r]=min(dp[l][r],dfs(l+1,r)+cost[s[l]-'a']);
dp[l][r]=min(dp[l][r],dfs(l,r-1)+cost[s[r]-'a']);
return dp[l][r];
}
int main()
{
int i;
while(scanf("%d%d",&n,&m)!=EOF)
{
scanf("%s",s);
int add,del;
for(i=1;i<=n;i++)
{
scanf("%s%d%d",sr,&add,&del);
cost[sr[0]-'a']=min(add,del);
}
memset(dp,-1,sizeof(dp));
printf("%d\n",dfs(0,m-1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: