您的位置:首页 > 其它

POJ1007 DNA Sorting

2015-01-05 13:00 316 查看
DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 85026 Accepted: 34238
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

East Central North America 1998
#include <stdio.h>
#include <string.h>
#include <algorithm>
using std::sort;
#define maxn 102

struct Node {
int inverNum;
char str[52];
} arr[maxn];
int N, M;

bool cmp(Node a, Node b) {
if(a.inverNum == b.inverNum)
return false;
return a.inverNum < b.inverNum;
}

int getInver(char *str) {
int sum = 0, i, j;
for(i = 0; i < N - 1; ++i)
for(j = i + 1; j < N; ++j)
if(str[i] > str[j]) ++sum;
return sum;
}

int main() {
// freopen("stdin.txt", "r", stdin);
int i, j;
while(scanf("%d%d", &N, &M) == 2) {
for (i = 0; i < M; ++i) {
scanf("%s", arr[i].str);
arr[i].inverNum = getInver(arr[i].str);
}
sort(arr, arr + M, cmp);
for (i = 0; i < M; ++i)
puts(arr[i].str);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ1007