您的位置:首页 > 其它

poj1797 Heavy Transportation(最短路变形)

2015-01-04 17:08 387 查看
Heavy Transportation

Time Limit: 3000MSMemory Limit: 30000K
Total Submissions: 21274Accepted: 5646
Description

Background

Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed
on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's
place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing
of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for
the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany
/*
跟上一题有点像,但是不一样,上一题是求某条路中间距离的最大值是所有路中间距离最大值的最小的值,而这个是求某条路中间的最小值是所有路中的最小值得最大值,也就是从起点到终点选一条路使得这条路的最小值的比其他所有路中间的最小值都大  加油!!!
Time:2015-1-4 17:03
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF=0x3f3f3f3f;
const int MAX=1010;
int n,m;
int g[MAX][MAX];
int dis[MAX];
bool vis[MAX];
void Dijkstra(){
    for(int i=1;i<=n;i++){
        dis[i]=g[1][i];
    }
    memset(vis,0,sizeof(vis));
    dis[1]=0;vis[1]=true;
    for(int i=1;i<=n;i++){
        int u=1,maxV=-1;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&maxV<dis[j]){
                u=j;
                maxV=dis[j];
            }
        }vis[u]=true;
        if(maxV==-INF)break;
        for(int j=1;j<=n;j++){//相当于求从1--n所有的路径中(路径中最小的值)的最大值
            if(!vis[j]&&dis[j]<min(dis[u],g[u][j])){
                dis[j]=min(dis[u],g[u][j]);
            }
        }
    }
    printf("%d\n\n",dis
);
}
int main(){
    int T,nCase=1;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        memset(g,0,sizeof(g));
        int u,v,w;
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&u,&v,&w);
                g[u][v]=g[v][u]=w;
        }
        printf("Scenario #%d:\n",nCase++);
        Dijkstra();
    }
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: